Scenario Answers

The answers provided in this section are not necessarily the only possible answers to the questions. The questions are designed to test your knowledge and to give practical exercise in certain key areas. This section is intended to test and exercise skills and concepts detailed in the body of this chapter.

If your answer is different, ask yourself whether it follows the tenets explained in the answers provided. Your answer is correct not if it matches the solution provided in the book, but rather if it has included the principles of design laid out in the chapter.

In this way, the testing provided in these scenarios is deeper: It examines not only your knowledge, but also your understanding and ability to apply that knowledge to problems.

If you do not get the correct answer, refer to the text and review the subject tested. Be certain to also review your notes on the question to ensure that you understand the principles of the subject.

Scenario 7-1 Answers

1.Explain the purpose of the virtual link in Figure 7-13.
In this example, Area 1 does not have a direct physical connection into Area 0. A virtual link must be configured between Router A and Router B. Area 2 is to be used as a transit area, and Router B is the entry point into Area 0. This way, Router A and Area 1 will have a logical connection to the backbone.
2.Does the topology map in Figure 7-14 show a valid design?
Yes, the topology map in Figure 7-14 shows a valid design.
3.Why would a company implement this design?
OSPF allows linking discontinuous parts of the backbone using a virtual link. In some cases, different Area 0s need to be linked together. This can occur, for example, if a company is trying to merge two separate OSPF networks into one network with a common Area 0. In other instances, virtual links are added for redundancy in case some router failure causes the backbone to be split in two. Whatever the reason might be, a virtual link can be configured between separate ABRs that touch Area 0 from each side and that have a common area between them.

Scenario 7-2 Answers

Q1:Refer to Figure 7-15 and design the addressing scheme for the network. Then write the configuration for the central router.
Table 7-7 shows a possible addressing scheme using the criteria stated in Scenario 7-1. Taking the private address, there is a great deal of flexibility in the addressing scheme that can be devised. Remember, however, that careful filtering is required if the organization is to connect to the Internet.

Table 7-7. Allocation of Addresses for Scenario 7-2
AreaSubnet/PrefixSubnet RangeReasons to use of the 0s in the second octet is an easy reminder that you are in Area 0. Because Area 0 is a transit area, it will be small. The addressing within the area would be allocated the prefix of 28 bits, allowing the range of subnets shown. The number of hosts on each of these subnets would be 15. to, the private addressing of as a Class A address is so large that full use can be made of the documentation advantages of the addressing scheme. The second octet allows Area 2 to be identified. The prefix of 22 bits is used within the area. This allows 1022 hosts on each network, which is good for further VLSM and VLANs in switched environments.
310.3.0.0/2410.3.0.0The second octet identifies the area. Within the area, a 24-bit prefix is used to address the LANs.

. . .
Ethernet: to

Serial: to
The second octet identifies the area. Within the area, a 30-bit mask is used to identify the serial links on which only two addresses are needed. The subnet was chosen as the subnet to sub-subnet for the serial links simply to ease troubleshooting; all serial links in the company in any area would be assigned the third octet of 100. A 28-bit mask was chosen for the Ethernet connections to allow the creation of many subnets.

The addressing scheme proposed here is broken out by area. It is not exhaustive in terms of designing an addressing policy down to the LAN level; instead, it deals with the principles of addressing and summarization.

Note in the allocation of addresses that this scenario deals with the allocation of subnets. The addresses displayed in this table are the address ranges of the available subnets, given the prefix length.

Example 7-15 demonstrates a sample configuration for Scenario 7-2. The configuration file is for the central router.

Example 7-15. Sample Configuration of Scenario 7-2

Router(config)# router ospf 100
Router(config-router)# network area 0
! Network Commands
Router(config-router)# network area 2
Router(config-router)# network area 3
Router(config-router)# network area 4
Router(config-router)# area 3 stub no-summary
! Totally Stubby Area
Router(config-router)# area 4 stub
! Stub Area
Router(config-router)# area 0 range
! Summarization between areas
Router(config-router)# area 2 range
Router(config-router)# area 3 range
Router(config-router)# area 4 range
Router(config)# interface e0
Router(config-if)# ip address
Router(config)# interface e1
Router(config-if)# ip address
Router(config)# interface e2
Router(config-if)# ip address
!Election of Designated Router
Router(config-if)# ip ospf priority 64
Router(config)# interface e3
Router(config-if)# ip address
Router(config-if)# ip ospf priority 0
!Ensures Router not elected as Designated Router
Router(config)# interface e4
Router(config-if)# ip address
Router(config-if)# ip ospf priority 0
!Ensures Router not elected as Designated Router
Router(config)# interface e5
Router(config-if)# ip address
Router(config)# interface e6
Router(config-if)# ip address
Router(config)# interface e7
Router(config-if)# ip address
Router(config)# interface s0
Router(config-if)# ip address
Router(config)# interface s1
Router(config-if)# ip address
Router(config)# interface loopback 0
!Router ID set by configuring loopback command
Router(config-if)# ip address


Scenario 7-3 Answers

1.There are problems with Router B. There is inconsistency in the routing table, and the system is extremely slow. What commands would be used to identify the problem? In examining the diagram and configuration, what problems can you see?
Router B has been configured to be the designated router for the LAN, which means that it is dealing with all the traffic on the LAN associated with the management of OSPF. Given that the system is an older Cisco router, it is a poor choice for a designated router. A better choice would be Router A, which is a larger system that connects directly to Area 0, making it a better choice from the standpoint of the network design. If Router B were a larger system, there could be an argument for making it the designated router to elevate Router A, which would otherwise be functioning as both the ABR and the designated router.

The router has not been configured as a stub, so the communication between Router A and Router B will be confused, preventing any communication between the two routers.

2.Router A is having problems connecting to Area 0. This is causing problems in other areas because Router A is used to connect to Area 0. What commands would be used to identify the problem? In examining the diagram and configuration, what problems can you see?
Router A is configured incorrectly. The command that would show the problem would be either show ip route, show ip protocols, or show ip ospf database. The lack of LSA traffic would indicate a configuration problem. When examining the configuration, you would see that the mask on the configuration of the network command for Area 0 is wrong. The mask for should be Using the mask of will place only interfaces with the IP address, which is a subnet address not an interface address. Therefore, there will be no communication of OSPF LSAs between the areas.
3.Issue the commands that would be used to correct the configuration problems that you see in the example configuration for Routers A and B.
The commands that would solve these problems are as follows:

On Router A:

router ospf 100
network area 0
interface fastethernet 1
no ip ospf cost 10
ip ospf priority 100

On Router B:

router ospf 200
network area 2
area 2 stub
interface FastEthernet0
no ip ospf priority 100

4.When you issue the show ip ospf interface command, you notice that there is a discrepancy in the timers on the link between Routers A and B. The transmit timer on Router A is set to 5, and the retransmit timer is set to 1. What problems would this cause? What command would be used to change the timers, and what are the default settings?
The default setting for the transmit timer is set to 1 second, and the retransmit timer is set to 5 seconds. The transmit timer determines the estimated number of seconds that it takes to send an LSA to a neighbor. The retransmit timer states the number of seconds to wait for an acknowledgment before retransmitting an LSA.

If the transmit timer is not smaller than the retransmit timer, the interface retransmits in the belief that the other side did not receive the LSA. This leads to excess traffic, confusion in the topology database, and the possibility of flapping links. To correct the settings, issue the following subinterface commands:

ip ospf retransmit-interval seconds
ip ospf transmit-delay seconds