Foundation Topics

Configuring EIGRP

Routers are able to route IP out of the box, but you need to configure static routes or a routing protocol so they can reach networks that are not directly connected.

EIGRP is classless, meaning that it advertises both a prefix and a mask with each route. Classless routing protocols are also able to arbitrarily summarize. EIGRP summarizes automatically at classful network boundaries, but you will also want to summarize within your network. EIGRP can summarize at any interface on any router, and summarization is extremely important in building a scalable EIGRP network.

The commands for EIGRP are similar to IP routing protocols.

This section covers the following:

  • Required commands for configuring EIGRP

  • Optional commands for EIGRP

  • Optional EIGRP commands specific to WANs

Required Commands for Configuring EIGRP

Like other interior routing protocols, the template for an EIGRP configuration involves turning on the protocol and identifying participating interfaces. EIGRP also uses an autonomous system (AS) to group routers. To run EIGRP, you must enable the following three items:

  • The EIGRP process— The routing protocol needs to be started on the router.

  • The EIGRP autonomous system number— Routers in the same administrative domain should be identified and grouped by a common AS number. This 16-bit number is arbitrary. Organizations that have a BGP AS will sometimes use that number; others just make up a number or use "AS 1." The significance of the AS is that a router will not become a neighbor with a router in a foreign AS.

  • Participating router interfaces— You can activate EIGRP on some or all interfaces. For instance, a router might run EIGRP on internal interfaces and BGP on external interfaces.

To enable EIGRP as an active routing protocol, use the router command. Remember that the AS must be consistent between routers to exchange updates.

Router(config)#router eigrp autonomous-system-number

At this point, EIGRP is enabled but not active on an interface. EIGRP will not produce hellos or advertise networks until it is activated on particular links.

Note

Most versions of the IOS software do not offer an error message when the configuration is incomplete, which can make troubleshooting more difficult. Refer to the section titled "Verifying the EIGRP Operation" later in this chapter for more information.


Interfaces are then attached to the EIGRP process with the network command. The network command is a pattern-matching tool: interfaces with IP addresses that match the pattern are active EIGRP speakers and those subnets are advertised through EIGRP.

There are two ways to utilize the network command. The first way is by classful network number.

Router(config-router)#network network-number

In this case, the network command in EIGRP is similar to the network command in RIP. A router with three interfaces—10.0.0.1, 10.1.1.1, and 192.168.0.1—configured with the network 10.0.0.0 command would speak EIGRP on two interfaces, but not on the 192.168.0.1 port.

In some cases, you might want to leave an interface that is within the classful network out of EIGRP. The command to do this is passive-interface. The passive-interface command prevents EIGRP from speaking on an interface; it does not send hellos or advertisements. Neighbors are not found on the passive interface and routes are not exchanged; however, the prefix of the passive interface is advertised to EIGRP neighbors on other interfaces.

The passive-interface command can be used on interfaces with no neighbors, or on interfaces that run another routing protocol (such as BGP).

For example, a router with two interfaces addressed 172.17.0.1 and 172.17.55.1 is configured in Example 4-1. EIGRP should run only on fastethernet0/0. Configuring the classful network (network 172.17.0.0) enables EIGRP on both interfaces. The passive-interface command is then used to suppress fastethernet0/1. Because EIGRP is active but quiet on fastethernet 0/1, the attached subnet (172.17.55.0/24) is advertised to neighbors through fastethernet0/0.

Example 4-1. The EIGRP passive-interface Command

Router(config)#interface fastethernet0/0
Router(config-if)#ip address 172.17.0.1 255.255.255.0
Router(config-if)#interface fastethernet0/1
Router(config-if)#ip address 172.17.55.1 255.255.255.0
Router(config-if)#router eigrp 100
Router(config-router)#network 172.17.0.0
Router(config-router)#passive-interface fastethernet0/1

Note

As shown in Example 4-1, you do not have to exit back to global-configuration mode to move between sub-configuration modes.


The network command for EIGRP can also be stated with a mask option. This allows you to identify specific interfaces for EIGRP. Routes that match the network and mask will run EIGRP and those subnets will be advertised.

This alternative syntax (first supported in IOS 12.0(4)T) is

Router(config-router)#network network-number [wildcard-network-mask]

To repeat the previous example, a router with interfaces numbered 172.17.0.1 and 172.17.55.1 needs to run EIGRP only on fastethernet0/0. Using the mask option allows the administrator to identify a specific interface, as shown in Example 4-2.

Example 4-2. EIGRP network mask Command

Router(config)#interface f0/0
Router(config-if)#ip address 172.17.0.1 255.255.255.0
Router(config-if)#interface f0/1
Router(config-if)#ip address 172.17.55.1 255.255.255.0
Router(config)#router eigrp 100
Router(config-router)#network 172.17.0.1 0.0.0.0

There is an important difference between the passive-interface and network mask techniques. The passive-interface command forces an interface to be quiet, but advertises the connected network out other interfaces. Interfaces left out of network mask do not speak EIGRP and subnets attached to those interfaces are not advertised.

Once interfaces have been selected for EIGRP, the next order of business is to meet and greet neighbors and exchange routes.

At this point, EIGRP is completely configured. It is possible to "tune" it a bit, and the following sections describe how to do so with optional commands. As the discussion turns to these optional commands, do not lose sight of one of the most important features of EIGRP: EIGRP makes smart decisions (such as bandwidth utilization and summarization) automatically and is thus easy to configure and troubleshoot. Many of the optional tuning commands are unnecessary because EIGRP defaults are effective in most cases.

Optional Commands for Configuring EIGRP

Optional commands described in this section are summarized in Table 4-2.

Table 4-2. Optional Commands for Configuring EIGRP
CommandDescription
no auto-summaryTurns off automatic classful summarization.
ip summary-addressManually configures summarization.
eigrp stubConfigures a stub router.
varianceConfigures unequal proportional load balancing.
ip hello-interval eigrp autonomous-system-number secondsChanges the hello frequency.
ip hold-time eigrp autonomous-system-number secondsChanges the length of time before a neighbor is considered dead.
bandwidthChanges the bandwidth setting on an interface, which is used to calculate the EIGRP metric and the maximum percentage of bandwidth to which EIGRP traffic will limit itself.
ip bandwidth-percent eigrp as-numberChanges the maximum amount of bandwidth EIGRP traffic will use. The default is 50%.


Summarization with EIGRP

It cannot be said enough: Scalability comes from summarization. Like other routing protocols, summarization is important to EIGRP because it limits advertisements, minimizes the size and optimizes the speed of the routing table, limits route recalculation, and holds down the amount of memory and processor resources consumed. Smaller routing tables make for faster networks.

Summarization in EIGRP also solves a problem unique to EIGRP: query scoping. EIGRP queries do not stop until they come to a dead-end; because of this, they can loop. Route convergence cannot proceed until all replies have been received. Summarization limits queries by stating: "only these routes are found past this point." Summarizing at logical points in the network is important to prevent stuck in active (SIA).

In IOS versions before 12.2(8), summarization automatically happens at classful network boundaries. Automatic summarization is an example of EIGRP trying to be helpful; however, if your network uses more than one classful network—for example, some enterprises use 10.0.0.0/8 and 192.168.x.0/24 networks concurrently—automatic summarization may create problems in some situations and should be disabled.

Summarization may be manually applied at any point in the network. You can configure manual summarization on any router interface. Consider summarization for both upstream and downstream neighbors. Upstream neighbors should receive a consolidated route, and downstream neighbors can receive a default route.

There are two commands for summarization with EIGRP: no auto-summary and ip summary-address eigrp autonomous-system-number address mask. The no auto-summary command disables automatic summarization. With no auto-summary configured, all known subnets are advertised out of each interface, limited only by split-horizon.

The ip summary-address eigrp command is used to announce a specific range on a particular interface. This allows bidirectional summarization and allows summarization to be more widely utilized.

Manual summarization is configured at the interface level, as shown here:

Router(config)#interface S0
Router(config-if)#ip summary-address eigrp autonomous-system-number address mask

					  

For example, imagine a router that connects to the corporate network and to a division with IP subnets such as 172.20.0.0/24, 172.20.1.0/24. . . 172.20.31.0/24 on serial 1/1. It also has a default route on serial 1/0. Configuration of manual summarization is done at the interface level. The corporation uses AS 100. This is shown in Example 4-3.

Example 4-3. EIGRP Summarization

Router(config)#interface S1/0
Router(config-if)#ip summary-address eigrp 100 172.20.0.0 255.255.224.0
Router(config-if)#interface S1/1
Router(config-if)#ip summary-address eigrp 100 0.0.0.0 0.0.0.0

Thus the division is summarized to the larger network and receives back a simple default route.

Caution

Summarizing the default route can be a useful technique. However, if used in cases where there are multiple default paths, this will reduce routing options and prevent failover to alternate paths when the primary path fails.


Stub Routers

Cisco IOS software release 12.0 made it possible for you to configure a remote router as an EIGRP stub router. Stub routers in EIGRP networks use EIGRP to send limited information between the stub and the core routers. A stub router is typically used on routers to minimize memory and processor utilization; as such it is a good candidate for slow routers with minimal memory.

The stub router has only one neighbor, a distribution layer router. The remote router only needs a default route pointing to the distribution router—everywhere else can be reached via that router.

Configuring a router as a stub also helps the rest of the network. Queries are responded to much quicker and convergence happens much faster. Sometimes a query can cause delays that result in the path being SIA. If the stub configuration is applied, the router responds to queries as inaccessible, thus limiting the scope of the query range and preventing SIA from occurring.

The following command structure shows the syntax of the eigrp stub command:

Router(config-router)# eigrp stub [receive-only | connected | redistributed | static | summary]

					  

Table 4-3 explains the options further. The third column shows that some optional commands may be combined on a single command line, while others require a separate eigrp stub command.

Table 4-3. The eigrp stub Option Syntax and Description
ParameterOn by DefaultMay Be CombinedDescription
receive-onlyNoNo(optional) Prevents the router from advertising routes.
connectedYesYes(optional) Permits advertisement of connected routes.
staticNoYes(optional) Permits redistribution of static routes.
summaryYesYesAdvertises summary routes.


Figure 4-1 shows a group of routers connected over WAN links. These routers are stub routers because they have no other networks connected to them.

Figure 4-1. Stub Routers

[View full size image]


Example 4-4 is the configuration for Router B in Figure 4-1.

Example 4-4. The eigrp stub Router Command

RouterB(config)#router eigrp 100
RouterB(config-router)#network 10.0.0.0 255.0.0.0
RouterB(config-router)#eigrp stub

This is obviously a simplified example, but it does raise an interesting point. This network could be configured with static routes. By using eigrp stub, the on-site technician can simply copy an example configuration into the router and change the IP addresses without having to understand EIGRP. Some organizations use EIGRP in hub-and-spoke topologies because it standardizes the configuration and fits situations where on-site technicians are not as familiar with IP and EIGRP.

Load Balancing in EIGRP

EIGRP automatically load balances across equal-cost links. The exact mechanism depends on the internal switching process of the router. You can also configure EIGRP to load balance proportionally across unequal-cost paths using the variance command.

When variance is used, the metric of the best path is multiplied by the variance. Alternate paths with a feasible distance lower than that product are used for load balancing. The command syntax is simply the keyword variance and the whole number multiplier:

Router(config-router)#variance multiplier

The multiplier argument is a whole number from 1 to 128. The default is 1, which means equal-cost load balancing.

Caution

When using variance, remember the following important points:

  • A variance of two or three is almost always appropriate—use higher values with caution. At a certain point, EIGRP will start activating old 28.8 modems to load-balance with DS1s.

  • Variance should be used cautiously with delay-sensitive traffic. A DS1 link takes 8 ms to transmit a 1500 B packet, while a 256-kbps link takes 47 ms. Voice over IP (VoIP) traffic, if shared between the two links, would perceive the difference as 39 ms of jitter.

    Cisco Voice over IP (CVoice), Second Edition, by Kevin Wallace, is a great resource for more information about delay and its effect on voice (Cisco Press, 2006).


If the variance number is higher than the default value of 1, the EIGRP process multiplies the best (lowest) metric by the variance. All paths to the same destination that have metrics less than this product are now included in load balancing. The amount of traffic sent over each link is proportional to the metric for the path.

Figure 4-2 shows EIGRP metrics to 192.168.5.0/24. To demonstrate the variance command, consider Router B.

Figure 4-2. EIGRP Distance and the variance Command

[View full size image]


Example 4-5 shows the configuration of the variance command.

Example 4-5. The variance Command

RouterB(config)#router eigrp 100
RouterB(config-router)#variance 2

Because the clockwise metric is about five million, a variance of two will load-balance with paths less than ten million. Because the counterclockwise metric is about six million, six packets will go clockwise for every five that go counterclockwise.

Note

Only those paths that are in the topology table as feasible successors are eligible to be included in the variance command.


Tuning the EIGRP Process

You can tune a network in many ways. Load balancing and summarizing routes are probably the two most important ways, but other techniques include reducing the frequency of the hello and hold timers.

There is a trade-off between reducing the hello traffic and maintaining the stability of the network. Fewer hellos, for example, result in the network taking longer to notice a failure, which in turn delays convergence. When the network does not have an accurate understanding of the available routes, the router cannot forward packets correctly.

EIGRP only sends updates when a new route is advertised or an existing route is withdrawn (changes state to down). Link failure causes an interface to change state without delay. But when a failed neighbor is not directly connected (on the other side of an Ethernet switch, for example), the only way to notice the change is to notice that hellos are no longer received. Neighborship is important because it alerts the router to topology changes and because the router is responsible to the rest of the network to publicize the lost routes.

Change the timers only after careful consideration. In the majority of cases, the default values are reasonable. Instead of improving performance, changing timers can create issues if not done deliberately. For instance, timers are changed per interface and changing the timers on only one side of a link can create a problem where a neighborship forms and dissolves periodically.

Timer values default based on the speed of the interface. Because the timers are assumed based on speed, they will usually be the same.

Timers are not communicated between neighbors and are not a requirement for neighborship. If Router A has a hello interval of 5 seconds and a hold timer of 15 seconds and Router B has a hello interval of 30 seconds, then the two routers will be neighbors for 15 seconds and then down for 15 seconds. Both the hello timer and the hold timer are discussed in the next sections.

The Hello Timer

Tuning the hello timer directly affects the ability of the network to notice a change in the state of a neighbor. Only after a router's interface is recognized as being down, or the router has failed to hear from a neighbor after a certain amount of time, does the router declare the neighbor dead and take action to update the routing table and neighbors.

For these reasons, the ip hello-interval eigrp command is typically used to decrease the time between hellos to ensure that the network converges quickly.

The defaults for the hello timer are as follows:

  • High-bandwidth links (every 5 seconds):

    - Broadcast media, such as Ethernet, Token Ring, and FDDI

    - Point-to-point serial links, such as PPP or HDLC leased circuits, Frame Relay point-to-point subinterfaces, and ATM

    - Point-to-point subinterfaces

    - High bandwidth (greater than T1) multipoint circuits, such as ISDN PRI and Frame Relay

  • Low-bandwidth links (every 60 seconds):

    - Multipoint circuits T1 bandwidth or slower, such as Frame Relay multipoint interfaces, ATM multipoint interfaces, and ATM

    - Switched virtual circuits and ISDN BRIs

The command to change how often the hellos are sent to neighbors is

Router(config-if)#ip hello-interval eigrp autonomous-system-number seconds

Notice that the command is applied to an interface and does not affect the default interval on other interfaces. The autonomous system number ties the command to a particular EIGRP process. The last variable then changes the default hello interval. Example 4-6 shows the hello interval on serial0/0 changing to 10 seconds.

Example 4-6. Hello Timer

Router(config)#interface Serial 0/0
Router(config-if)#ip hello-interval eigrp 100 10

This command is very useful with nonbroadcast multiaccess (NBMA) WAN links. EIGRP uses a 60-second hello timer for Frame Relay by default.

The Hold Timer

The hold time is how long the router waits for a hello before pronouncing a neighbor unavailable. By default, the hold time is three times the hello time but changing the hello interval does not automatically change the hold time. The hold timer for an interface must be changed manually using the ip hold-time eigrp command, as follows:

Router(config-if)#ip hold-time eigrp autonomous-system-number seconds

The command is specific to an interface and EIGRP AS. Example 4-7 shows the hold interval on serial0/0 changing to 30 seconds.

Example 4-7. Hold Timer

Router(config)#interface serial0/0
Router(config-if)#ip hold-time eigrp 100 30

Authentication

EIGRP supports two forms of authentication: simple passwords and MD5 hashes. Simple passwords are sent as plain-text and matched to the key on the receiver. Simple passwords are not secure, because any listener can see this traffic and read the key value. Because simple passwords do not accomplish a change in the security structure in your network, the commands to implement them are not discussed here.

Hashed keys, sent as MD5 values, are secure because a listener cannot use the value in one transmission to compute the key.

Using MD5 Authentication, the router generates a hash value for every EIGRP transmission and checks the hash of every received EIGRP packet.

To specify MD5 authentication, the command is

router(config-if)#ip authentication mode eigrp autonomous-system md5

Once MD5 is specified, the command to set the key is

router(config-if)#ip authentication key-chain eigrp autonomous-system chain-name

					  

Finally, the key-chain is configured and the key is specified:

router(config-if)#key chain chain-name
router(config-if)#key key-id
router(config-keychain-key)#key-string key

An example configuration in AS 100 might therefore look like the following:

router(config-if)#ip authentication mode eigrp 100 md5
router(config-if)#ip authentication key-chain eigrp 100 my-chain
router(config)#key chain my-chain
router(config-keychain)#key 1
router(config-keychain-key)#key-string secret

Authentication results are not shown under the show commands; authentication must be assumed based on the successful establishment of neighborship. However, the debug eigrp packets command does show the process.

Optional EIGRP Commands over WANs

There are EIGRP design and configuration issues concerning WANs. Here you must deal with limited capacity to a greater degree than at other points in the network. Furthermore, routing updates and data transmissions compete for that limited space.

EIGRP is unique in that it restricts its use of bandwidth. By default, it uses no more than half the link capacity, which is superior to the scant consideration shown by every other routing protocol. Although the default setting for EIGRP is usually sufficient, you may need to adjust it at times. The following sections describe the commands necessary to make these changes.

EIGRP Defaults in Bandwidth Utilization

Routers usually understand link capacity. Serial interfaces are problematic in this regard, though, because they usually attach through a DSU. The router therefore assumes a default serial speed of 1544 kbps.

If the link is 56 kbps, however, EIGRP would calculate an inaccurate metric and—even limiting itself to 772 kbps—could saturate the link. This could result in dropped EIGRP and data packets because of congestion.

The show interface command allows you to check that the interface bandwidth is accurate. The output shows the configured bandwidth of the link.

Example 4-8 shows the bandwidth of serial0.

Example 4-8. Bandwidth

Router# show interface serial 0
Serial0 is up, line protocol is up
Hardware is HD64570
Description: to Internet
Internet address is 172.25.146.182/30
MTU 1500 bytes, BW 1280 Kbit, DLY 20000 usec, rely 255/255, load 1/255
...

Note that, in this case, the bandwidth has been adjusted to 1280 kbps.

The bandwidth does not affect the actual speed of the link. It is used for routing-protocol calculations and load calculations. The following sections provide additional guidelines about bandwidth configuration.

In general, the bandwidth is set using the bandwidth command. The following syntax shows the structure of the command:

Router#interface S0
Router(config-if)#bandwidth speed-of-line

Configuring Bandwidth over an NBMA Cloud

EIGRP works well over all WANs, including point-to-point and NBMA environments such as Frame Relay or ATM. The NBMA topology can include either point-to-point subinterfaces or multipoint interfaces.

Cisco identifies three rules that you should follow when configuring EIGRP over an NBMA cloud:

  • EIGRP traffic should not exceed the committed information rate (CIR) capacity of the virtual circuit (VC).

  • EIGRP aggregated traffic over all the VCs should not exceed the access line speed of the interface.

  • The bandwidth allocated to EIGRP on each VC must be the same in both directions.

If you understand and follow these rules, EIGRP works well over the WAN. If you do not take care in the configuration of the WAN, EIGRP can swamp the network.

Note

Come back and look through this section after you have read about OSPF support for Frame Relay. OSPF over Frame Relay is complicated and contrasts with the simple implementation of EIGRP over Frame Relay. EIGRP handles whatever topology that is thrown at it without requiring a special configuration.


Configuring Bandwidth over a Multipoint Network

In addition to being used in the EIGRP metric, the bandwidth command influences how EIGRP uses NBMA virtual circuits (VCs). If the serial line has many VCs in a multipoint configuration, EIGRP will assume that each VC has an even share of bandwidth. EIGRP will confine itself to using half that share for its traffic. This limitation is important—no other routing protocol does this—but will work best if the bandwidth is correctly defined. A 56-kbps link that has a bandwidth set to 128 kbps will not benefit from restraint shown by EIGRP.

The bandwidth command should reflect the access-link speed into the Frame Relay cloud. Your company might have five PVCs from your router's serial interface, each carrying 56 kbps. The access link will need a capacity of 5 * 56 kbps (280 kbps).

Configuring Bandwidth over a Hybrid Multipoint Network

If the multipoint network has differing speeds allocated to the VCs, a more complex solution is needed. There are two main approaches:

  • Take the lowest CIR and multiply it by the number of circuits. Apply the product as the bandwidth of the physical interface. The problem with this configuration is that EIGRP will underutilize the higher-bandwidth links.

  • If possible, it is much easier to configure and manage an environment that has used subinterfaces, where a VC is logically treated as if it were a separate interface. The bandwidth command can be configured on each subinterface, which allows different speeds on each VC. In this solution, subinterfaces are configured for each VC and the CIR is configured as the bandwidth. Cisco recommends this as the preferred solution.

Configuring the Pure Point-to-Point Network

If there are many VCs, there might not be enough bandwidth at the access speed of the interface to support the aggregate EIGRP traffic. The subinterfaces should be configured with a bandwidth that is much lower than the real speed of the circuit. In this case, it is necessary to use the bandwidth-percent command to indicate to the EIGRP process that it can still function.

The ip bandwidth-percent-eigrp command adjusts the percentage of capacity that EIGRP may use from the default fifty percent. You would use this command because the bandwidth command does not reflect the true speed of the link. The bandwidth command might have been altered to manipulate the routing metric and path selection of a routing protocol (but it might be better to use other methods of controlling the routing metric and return the bandwidth to a true value). The following shows the structure of the ip bandwidth-percent eigrp command:

Router(config)#interface S0
Router(config-if)#ip bandwidth-percent eigrp autonomous-system-number percent

					  

Verifying the EIGRP Operation

It is important to understand the output of the show commands to prepare for the exam. The ability to interpret these show command output examples in conjunction with the physical and logical topology diagrams of your organization will ensure your understanding of the operation of EIGRP.

This section describes the show commands shown in Table 4-4.

Table 4-4. EIGRP show Commands
Command OptionDescription
show ip eigrp neighborsGives detailed information about neighbors. This command records the communication between the router and the neighbors in addition to the interface and address by which they communicate.
show ip eigrp topologyGives details about the routes held in the topology table, detailed information on the networks that the router is aware of and the preferred paths to those networks, and the next hop in the path. Also allows the router to track EIGRP packets that have been sent to neighbors.
show ip eigrp trafficGives information about the aggregate traffic sent to and from the EIGRP process.


The EIGRP show commands are highly detailed and give a comprehensive understanding of the state of the network. Troubleshooting EIGRP should start with the generic routing commands show ip route and show ip protocols, before continuing with EIGRP-specific troubleshooting.

The show ip eigrp neighbors Command

The show ip eigrp neighbors command shows the neighbor table. The syntax is

Router#show ip eigrp neighbors [type number]

Example 4-9 shows the output of this command.

Example 4-9. The show ip eigrp neighbors Command Output

Router# show ip eigrp neighbors
IP-EIGRP Neighbors for process 100
Address          interface    Holdtime   Uptime   Q      Seq    SRTT    RTO
                              (secs)     (h:m:s)  Count  Num    (ms)    (ms)
140.100.48.22    Ethernet1    13         0:00:41  0      11     4       20
140.100.32.22    Ethernet0    14         0:02:01  0      10     12      24
140.100.32.31    Ethernet0    12         0:02:02  0      4      5       2

					  

Table 4-5 explains the meaning of the important fields in Example 4-9.

Table 4-5. Explanation of the show ip eigrp neighbors Command Output
FieldExplanation
process 100Autonomous system number.
AddressIP address of the EIGRP neighbor.
InterfaceInterface the router receives hellos on.
HoldtimeLength of time, in seconds, that the router will wait before declaring the link down.
UptimeTime (in hours, minutes, and seconds) since the router first heard from this neighbor.
Q CountNumber of EIGRP packets (update, query, and reply) that the router has queued.
Seq NumThe sequence number of the last packet received from the neighbor.
SRTTSmooth round-trip time. The time (in milliseconds) from the sending of the packet to the receipt of an acknowledgment from the neighbor.
RTORetransmission timeout, in milliseconds. This shows how long the router will wait for an acknowledgment before it retransmits the packet.


The show ip eigrp topology Command

The show ip eigrp topology command shows the topology table. This command shows the effect of DUAL, which is described in Chapter 3. It shows whether the successor or the route is in an active or passive state and if there is a feasible successor. The syntax is

Router#show ip eigrp topology [autonomous-system-number | [[ip-address] mask]]

					  

Example 4-10 shows the output of this command.

Example 4-10. The show ip eigrp topology Command Output

Router# show ip eigrp topology
IP-EIGRP Topology Table for process 100
Codes:P - Passive, A - Active, U - Update, Q - Query, R – Reply, r - Reply status
P 140.100.56.0 255.255.255.0, 2 successors, FD is 0
via 140.100.32.22 (46251776/46226176), Ethernet0
via 140.100.48.22 (46251776/46226176), Ethernet1
via 140.100.32.31 (46277376/46251776), Ethernet0
P 140.100.48.0 255.255.255.0, 1 successors, FD is 307200
via Connected, Ethernet1
via 140.100.48.22 (307200/281600), Ethernet1
140.100.32.22 (307200/281600), Ethernet0
via 140.100.32.31 (332800/307200), Ethernet0

					  

Table 4-6 explains the meaning of the important fields in Example 4-10.

Table 4-6. Explanation of the show ip eigrp topology Command Output
FieldExplanation
PPassive—The router has not received any EIGRP input from a neighbor, and the network is assumed to be stable.
AActive—When a route or successor is down, the router attempts to find an alternative path. The router is currently actively querying for a backup path.
UUpdate—A value in this field identifies that the router has sent an update packet to a neighbor.
QQuery—A value in this field identifies that the router has sent a query packet to a neighbor.
RReply—A value here shows that the router has sent a reply to the neighbor.
rThis is used in conjunction with the query counter; the router has sent out a query and is awaiting a reply.
140.100.48.0Destination IP network number.
255.255.255.0Destination subnet mask.
successorsThis is the number of routes or the next logical hop. The number stated here is the same as the number of applicable routes in the routing table.
viaThis is the next-hop address. The first of these entries are the current successors. The remaining entries on the list are feasible successors.
(46251776/46226176)The first number is the EIGRP metric. After the slash is the EIGRP metric the peer advertised, or the advertised distance.
Ethernet0The interface through which the EIGRP advertisement was received and the outgoing interface.


The show ip eigrp traffic Command

The show ip eigrp traffic command shows the EIGRP traffic received and generated by the router. The command syntax is

Router#show ip eigrp traffic [autonomous-system-number]

Example 4-11 shows the output of this command.

Example 4-11. The show ip eigrp traffic Command Output

Router# show ip eigrp traffic
IP-EIGRP Traffic Statistics for process 100
Hellos sent/received: 218/205
Updates sent/received: 7/23
Queries sent/received: 2/0
Replies sent/received: 0/2
Acks sent/received: 21/14

Table 4-7 explains the meaning of the important fields in Example 4-11.

Table 4-7. Explanation of the show ip eigrp traffic Command Output
FieldExplanation
process 100Autonomous system number
Hellos sent/receivedNumber of hello packets sent and received by the router
Updates sent/receivedNumber of update packets sent and received by the router
Queries sent/receivedNumber of query packets sent and received by the router
Replies sent/receivedNumber of reply packets sent and received by the router
Acks sent/receivedNumber of acknowledgment packets sent and received by the router


Troubleshooting EIGRP

Having many methods and tools helps in troubleshooting any network. One of the most beneficial