Lab 10-3: Multi-AS BGP Topology

This BGP lab demonstrates several aspects of IBGP and EBGP in combination with a route reflector, peer groups, and a route server. It essentially consists of two different EBGP topologies and simulates stub, transit, and multi-exit autonomous systems using OSPF as underlying IGP as well as an exchange segment. The IGP fulfills the connectivity requirements of IBGP. The examples of this lab include the following:

  • EBGP mesh without a route server

  • EBGP at an exchange point featuring a Zebra route server

  • EBGP at an exchange point featuring Merrit's RSng (RSd, IRRd)

  • Looking-glass access to route servers

The lab also demonstrates redistribution of OSPF into BGP (redistribute ospf) in contrast to network statements for prefix announcements to EBGP neighbors. This is not always advisable, but it really depends on your individual situation.

Zebra does not support EBGP multipath (maximum-paths), but Cisco IOS architecture does. Keep in mind, however, that bgp-multipath only takes care of storing more than one path to a given prefix in the BGP table (which is a necessary condition for load balancing, but not a sufficient one). In fact, it is the FIB, not BGP, that really sees that those are two ECMP-eligible routes and uses them appropriately per-flow or per-packet.

With EBGP, directly connected peers (exchange network segment) or ebgp-multihop configuration with IGP resolution of loopbacks is required. Figure 10-8 shows the topology and address concept used throughout this part of the lab. Note that the networks 192.168.7.0/24 and 192.168.14.0/24 are considered "neutral" networks and are not announced by any EBGP participant. Figure 10-9 shows the logical BGP setup.

Figure 10-8. Multi-AS BGP Topology

[View full size image]
graphics/10fig08.gif


Figure 10-9. Logical BGP Topology with Shared EBGP Segment

graphics/10fig09.gif


Examples 10-11 through 10-17 present the relevant parts of the router OSPF and BGP configurations, nothing really fancy. To demonstrate two variants of origin, OSPF redistribution into BGP is used on callisto and castor, whereas laurel and scar use network statements to announce their prefixes to the exchange segment in contrast to the redistribution of connected routes you have seen in the previous lab. Callisto acts as a route reflector for the AS 65000 IBGP speakers.

Example 10-11. Castor OSPF and BGP Configuration

castor-ospfd# show running-config



Current configuration:

!

hostname castor-ospfd

password 8 4DwwIFdKLWvU.

enable password 8 dV8x4MhxDAuaw

log file /var/log/ospfd.log

service advanced-vty

service password-encryption

!

!

!

interface xl0

 ip ospf message-digest-key 1 md5 zebra

!

interface ed0

 ip ospf message-digest-key 1 md5 zebra

!

interface lp0

 ip ospf network point-to-point

!

interface sl0

 ip ospf network point-to-point

!

interface sl1

 ip ospf network point-to-point

!

interface ds0

!

interface stf0

!

interface faith0

!

interface vlan0

!

interface vlan1

!

interface lo0

!

interface ppp0

 ip ospf network point-to-point

!

interface ppp1

 ip ospf network point-to-point

!

interface vlan8

 ip ospf message-digest-key 1 md5 zebra

!

interface lo1

!

interface wpachdlc0

 ip ospf network point-to-point

!

router ospf

 ospf router-id 192.168.2.7

 compatible rfc1583

 redistribute connected

 redistribute static

 passive-interface ed0

 network 192.168.2.0/24 area 0

 network 192.168.80.0/24 area 0

 network 192.168.99.0/30 area 0

 area 0 authentication message-digest

 capability opaque

!

access-list 1 remark vty-protection

access-list 1 permit 127.0.0.1

access-list 1 permit 192.168.1.0 0.0.0.255

!

line vty

 access-class 1

 exec-timeout 15 0

!

end



castor-bgpd# show running-config



Current configuration:

!

hostname castor-bgpd

password 8 4DwwIFdKLWvU.

enable password 8 dV8x4MhxDAuaw

log file /var/log/bgpd.log

service advanced-vty

service password-encryption

!

router bgp 65000

 bgp router-id 192.168.2.7

 bgp cluster-id 1.1.1.1

 bgp dampening

 redistribute ospf

 neighbor 192.168.1.1 remote-as 65000

 neighbor 192.168.1.1 soft-reconfiguration inbound

 neighbor 192.168.7.254 remote-as 65003

 neighbor 192.168.7.254 soft-reconfiguration inbound

!

access-list 1 remark vty-protection

access-list 1 permit 127.0.0.1

access-list 1 permit 192.168.1.0 0.0.0.255

!

line vty

 access-class 1

 exec-timeout 15 0

!

end


Example 10-12. Ganymed OSPF and BGP Configuration

ganymed-ospfd# show running-config



Current configuration:

!

hostname ganymed-ospfd

password 8 bJFoEOB0obLL6

enable password 8 nVitURFKR/y3M

log file /var/log/ospfd.log

service advanced-vty

service password-encryption

!

!

!

interface lo0

!

interface lo1

!

interface ne3

 ip ospf message-digest-key 1 md5 zebra

!

interface ne4

 ip ospf message-digest-key 1 md5 zebra

!

interface ne5

!

interface ppp0

 ip ospf network point-to-point

!

interface ppp1

 ip ospf network point-to-point

!

interface tun0

 ip ospf network point-to-point

!

interface tun1

 ip ospf network point-to-point

!

interface enc0

!

interface vlan0

 ip ospf message-digest-key 1 md5 zebra

!

interface vlan1

!

interface gre0

 ip ospf network point-to-point

!

interface gif0

 ip ospf network point-to-point

!

interface gif1

 ip ospf network point-to-point

!

interface gif2

 ip ospf network point-to-point

!

interface gif3

 ip ospf network point-to-point

!

interface faith0

!

interface pflog0

!

interface sl0

 ip ospf network point-to-point

!

interface sl1

 ip ospf network point-to-point

!

interface bridge0

!

interface bridge1

!

router ospf

 ospf router-id 192.168.1.254

 compatible rfc1583

 redistribute connected

 redistribute static

 network 192.168.1.0/24 area 0

 network 192.168.2.0/24 area 0

 network 192.168.45.0/24 area 0

 network 192.168.80.0/24 area 0

 area 0 authentication message-digest

 capability opaque

!

access-list 1 remark vty-protection

access-list 1 permit 127.0.0.1

access-list 1 permit 192.168.1.0 0.0.0.255

!

line vty

 access-class 1

 exec-timeout 15 0

!

end



ganymed-bgpd# show running-config



Current configuration:

!

hostname ganymed-bgpd

password 8 bJFoEOB0obLL6

enable password 8 bJFoEOB0obLL6

log file /var/log/bgpd.log

service advanced-vty

service password-encryption

!

router bgp 65000

 bgp router-id 192.168.44.1

 bgp cluster-id 1.1.1.1

 bgp dampening

 neighbor 192.168.1.1 remote-as 65000

 neighbor 192.168.1.1 update-source lo1

 neighbor 192.168.1.1 soft-reconfiguration inbound

!

access-list 1 remark vty-protection

access-list 1 permit 127.0.0.1

access-list 1 permit 192.168.1.0 0.0.0.255

!

line vty

 access-class 1

 exec-timeout 15 0

!

end


Example 10-13. Callisto OSPF and BGP Configuration

callisto-ospfd# show running-config



Current configuration:

!

hostname callisto-ospfd

password 8 m6eyKycFMHniQ

enable password 8 bjYlnA9YLBWyM

log file /var/log/ospfd.log

service advanced-vty

service password-encryption

!

!

!

interface lo

!

interface eth0

!

interface eth1

 ip ospf message-digest-key 1 md5 zebra

!

interface ipsec0

!

interface ipsec1

!

interface ipsec2

!

interface ipsec3

!

interface eth1:1

 ip ospf message-digest-key 1 md5 zebra

!

interface lo1

!

interface wp1chdlc

 ip ospf network point-to-point

!

router ospf

 ospf router-id 192.168.1.1

 compatible rfc1583

 redistribute connected

 redistribute static

 passive-interface eth0

 network 192.168.1.0/24 area 0

 network 192.168.45.0/24 area 0

 network 192.168.99.0/30 area 0

 area 0.0.0.0 authentication message-digest

 capability opaque

!

access-list 1 remark vty-protection

access-list 1 permit 127.0.0.1

access-list 1 permit 192.168.1.0 0.0.0.255

!

line vty

 access-class 1

 exec-timeout 0 0

!

end



callisto-bgpd# show running-config



Current configuration:

!

hostname callisto-bgpd

password 8 m6eyKycFMHniQ

enable password 8 bjYlnA9YLBWyM

log file /var/log/bgpd.log

service advanced-vty

service password-encryption

!

router bgp 65000

 bgp router-id 192.168.1.1

 bgp cluster-id 1.1.1.1

 bgp dampening

 redistribute ospf

 neighbor INTERNAL peer-group

 neighbor INTERNAL remote-as 65000

 neighbor INTERNAL route-reflector-client

 neighbor INTERNAL soft-reconfiguration inbound

 neighbor 192.168.2.7 peer-group INTERNAL

 neighbor 192.168.14.2 remote-as 65001

 neighbor 192.168.14.2 soft-reconfiguration inbound

 neighbor 192.168.14.254 remote-as 65003

 neighbor 192.168.14.254 soft-reconfiguration inbound

 neighbor 192.168.44.1 peer-group INTERNAL

!

access-list 1 remark vty-protection

access-list 1 permit 127.0.0.1

access-list 1 permit 192.168.1.0 0.0.0.255

!

line vty

 access-class 1

 exec-timeout 0 0

!

end


Example 10-14. Scar OSPF and BGP Configuration

scar# show running-config

...

!

ip subnet-zero

!

interface Loopback0

 ip address 10.0.0.1 255.255.255.0

!

interface Ethernet0

 ip address 192.168.7.254 255.255.255.0

 no ip proxy-arp

!

interface Ethernet1

 ip address 192.168.14.254 255.255.255.0

!

interface TokenRing0

 ip address 10.0.1.1 255.255.255.0

 early-token-release

 ring-speed 16

!

router ospf 1

 router-id 10.0.0.1

 log-adjacency-changes

 area 0 authentication message-digest

 redistribute connected subnets

 redistribute static subnets

 passive-interface Ethernet0

 passive-interface Ethernet1

 passive-interface Serial0

 passive-interface Serial1

 passive-interface Serial2

 passive-interface Serial3

 passive-interface TokenRing1

 network 10.0.0.0 0.0.0.255 area 0

 network 10.0.1.0 0.0.0.255 area 0

 default-information originate

!

router bgp 65003

 no synchronization

 bgp router-id 10.0.0.1

 bgp cluster-id 1.1.1.1

 bgp log-neighbor-changes

 bgp dampening

 network 10.0.0.0 mask 255.255.255.0

 network 10.0.1.0 mask 255.255.255.0

 neighbor 10.0.1.2 remote-as 65003

 neighbor 10.0.1.2 update-source Loopback0

 neighbor 10.0.1.2 soft-reconfiguration inbound

 neighbor 192.168.7.7 remote-as 65000

 neighbor 192.168.7.7 soft-reconfiguration inbound

 neighbor 192.168.14.1 remote-as 65000

 neighbor 192.168.14.1 soft-reconfiguration inbound

 neighbor 192.168.14.2 remote-as 65001

 neighbor 192.168.14.2 soft-reconfiguration inbound

 maximum-paths 2

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.14.1

ip route 0.0.0.0 0.0.0.0 192.168.7.7 2

...


Example 10-15. Laurel OSPF and BGP Configuration

laurel# show running-config

...

ip subnet-zero

!

interface Loopback0

 ip address 172.16.0.254 255.255.255.128

!

interface Ethernet0

 ip address 192.168.14.2 255.255.255.0

!

interface Ethernet1

 ip address 172.16.0.1 255.255.255.128

 ip ospf message-digest-key 1 md5 7 061C0A235E4F

!

router ospf 1

 router-id 172.16.0.254

 log-adjacency-changes

 area 0 authentication message-digest

 redistribute connected subnets

 redistribute static subnets

 passive-interface Ethernet0

 passive-interface Serial0

 passive-interface Serial1

 network 172.16.0.0 0.0.0.127 area 0

 network 172.16.0.128 0.0.0.127 area 0

 default-information originate

!

router bgp 65001

 no synchronization

 bgp router-id 172.16.0.254

 bgp cluster-id 1.1.1.1

 bgp log-neighbor-changes

 bgp dampening

 network 172.16.0.0 mask 255.255.255.128

 network 172.16.0.128 mask 255.255.255.128

 neighbor 172.16.0.253 remote-as 65001

 neighbor 172.16.0.253 soft-reconfiguration inbound

 neighbor 192.168.14.1 remote-as 65000

 neighbor 192.168.14.1 soft-reconfiguration inbound

 neighbor 192.168.14.254 remote-as 65003

 neighbor 192.168.14.254 soft-reconfiguration inbound

 maximum-paths 2

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.14.1

ip route 0.0.0.0 0.0.0.0 192.168.7.7 2


Example 10-16. Chaplin OSPF and BGP Configuration

chaplin# show running-config

...

!

ip subnet-zero

!

interface Loopback0

 ip address 172.16.0.253 255.255.255.128

!

interface Ethernet0

 ip address 172.16.0.2 255.255.255.128

 ip ospf message-digest-key 1 md5 7 01090306490A

!

router ospf 1

 router-id 172.16.0.253

 log-adjacency-changes

 area 0 authentication message-digest

 redistribute connected subnets

 redistribute static subnets

 passive-interface Serial0

 passive-interface Serial1

 network 172.16.0.0 0.0.0.127 area 0

 network 172.16.0.128 0.0.0.127 area 0

!

router bgp 65001

 no synchronization

 bgp router-id 172.16.0.253

 bgp cluster-id 1.1.1.1

 bgp log-neighbor-changes

 bgp dampening

 neighbor 172.16.0.254 remote-as 65001

 neighbor 172.16.0.254 soft-reconfiguration inbound

!

ip classless

...


Example 10-17. Hardy OSPF and BGP Configuration

hardy# show running-config

...

!

ip subnet-zero

!

interface Loopback0

 ip address 10.0.0.2 255.255.255.0

!

interface TokenRing0

 ip address 10.0.1.2 255.255.255.0

 ip ospf network broadcast

 early-token-release

 ring-speed 16

!

router ospf 1

 router-id 10.0.0.2

 log-adjacency-changes

 area 0 authentication message-digest

 redistribute connected subnets

 redistribute static subnets

 network 10.0.0.0 0.0.0.255 area 0

 network 10.0.1.0 0.0.0.255 area 0

!

router bgp 65003

 no synchronization

 bgp router-id 10.0.0.2

 bgp cluster-id 1.1.1.1

 bgp log-neighbor-changes

 bgp dampening

 neighbor 10.0.0.1 remote-as 65003

 neighbor 10.0.0.1 update-source Loopback0

 neighbor 10.0.0.1 soft-reconfiguration inbound

!

ip classless

...


Example 10-18 demonstrates the result of this setup with several show commands. The last traceroute shows the effect of the BGP-multipath capability of Cisco IOS architecture using two equal-cost paths.

Example 10-18. Results of This EBGP Setup

[root@ganymed:~#] netstat -rn -f inet

Routing tables



Internet:

Destination        Gateway            Flags     Refs     Use    Mtu  Interface

default            211.11.117.1       UGS         4    10366   1500   ne5

10.0.0/24          192.168.1.1        UG1         0        0   1500   ne3

10.0.1/24          192.168.1.1        UG1         0        0   1500   ne3

127/8              127.0.0.1          UGRS        0        0  33224   lo0

127.0.0.1          127.0.0.1          UH          2        0  33224   lo0

172.16.0.0/25      192.168.1.1        UG1         0        0   1500   ne3

172.16.0.128/25    192.168.1.1        UG1         0        0   1500   ne3

192.168.1/24       link#1             UC          0        0   1500   ne3

192.168.1.1        52:54:5:e3:51:87   UHL         7     6620   1500   ne3

192.168.1.2        8:0:46:64:74:1b    UHL         1     2213   1500   ne3

192.168.1.254      127.0.0.1          UGHS        0        0  33224   lo0

192.168.2/24       link#2             UC          0        0   1500   ne4

192.168.2.7        0:10:5a:c4:2c:4    UHL         3      977   1500   ne4

192.168.7/24       192.168.2.7        UG1         0       33   1500   ne4

192.168.14/24      192.168.1.1        UG1         0        0   1500   ne3

192.168.44.1       192.168.44.1       UH          0        0  33224   lo1

192.168.45/24      link#1             UC          0        0   1500   ne3

192.168.45.253     52:54:5:e3:51:87   UHL         0        0   1500   ne3

192.168.80/24      link#16            UC          0        0   1496   vlan0

192.168.80.1       0:10:5a:c4:2c:4    UHL         0        0   1496   vlan0

192.168.99.1       192.168.1.1        UGH1        0        0   1500   ne3

192.168.99.2       192.168.2.7        UGH1        0        0   1500   ne4

211.11.117/24      link#3             UC          0        0   1500   ne5

211.11.117.1       0:0:c:7:ac:12      UHL         1        0   1500   ne5



[root@castor:~#] netstat -rn -f inet

Routing tables



Internet:

Destination        Gateway            Flags    Refs      Use  Netif Expire

default            192.168.2.254      UGSc        3       12    xl0

10/24              192.168.7.254      UG1c        0        0    ed0

10.0.1/24          192.168.7.254      UG1c        0        0    ed0

127.0.0.1          127.0.0.1          UH          0        0    lo0

172.16/25          192.168.2.254      UG1c        0        0    xl0

172.16.0.128/25    192.168.2.254      UG1c        0        0    xl0

192.168.1          192.168.2.254      UG1c        2        0    xl0

192.168.2          link#1             UC          1        0    xl0

192.168.2.254      52:54:05:e3:e4:2f  UHLW       14       33    xl0    679

192.168.7          link#2             UC          1        0    ed0

192.168.7.254      00:00:0c:1a:a9:a8  UHLW        4      516    ed0    583

192.168.44         192.168.2.254      UG1c        0        0    xl0

192.168.45         192.168.2.254      UG1c        0        0    xl0

192.168.80         link#15            UC          1        0  vlan8

192.168.80.254     52.54.5.e3.e4.2f   UHLW        0        0  vlan8    777

192.168.99.1       192.168.2.254      UGH1        0        0    xl0

192.168.99.2       192.168.99.1       UH          0        6 wpachd =>

192.168.99.2/32    wpachdlc0          U1c         0        0 wpachd

211.11.117         192.168.2.254      UG1c        0        0    xl0



castor-bgpd# show ip bgp summary

BGP router identifier 192.168.2.7, local AS number 65000

5 BGP AS-PATH entries

0 BGP community entries

Dampening enabled.



Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

192.168.1.1     4 65000      51      54        0    0   0 00:46:07        9

192.168.7.254   4 65003      55      54        0    0   0 00:46:43        4



Total number of neighbors 2



castor-bgpd# show ip bgp neighbors 192.168.1.1 received-routes

BGP table version is 0, local router ID is 192.168.2.7

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete



   Network          Next Hop            Metric LocPrf Weight Path

*> 10.0.0.0/24      192.168.14.254           0    100      0 65003 i

*> 10.0.1.0/24      192.168.14.254           0    100      0 65003 i

*> 172.16.0.0/25    192.168.14.2             0    100      0 65001 i

*> 172.16.0.128/25  192.168.14.2             0    100      0 65001 i

*> 192.168.2.0      192.168.1.254           20    100      0 ?

*> 192.168.44.0     192.168.1.254           20    100      0 ?

*> 192.168.80.0     192.168.1.254           20    100      0 ?

*> 192.168.99.1/32  192.168.1.1             10    100      0 ?

*> 211.11.117.0     192.168.1.254           20    100      0 ?



Total number of prefixes 9



castor-bgpd# show ip bgp

BGP table version is 0, local router ID is 192.168.2.7

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete



   Network          Next Hop            Metric LocPrf Weight Path

* i10.0.0.0/24      192.168.14.254           0    100      0 65003 i

*>                  192.168.7.254            0             0 65003 i

* i10.0.1.0/24      192.168.14.254           0    100      0 65003 i

*>                  192.168.7.254            0             0 65003 i

*>i172.16.0.0/25    192.168.14.2             0    100      0 65001 i

*                   192.168.7.254                          0 65003 65001 i

*>i172.16.0.128/25  192.168.14.2             0    100      0 65001 i

*                   192.168.7.254                          0 65003 65001 i

*> 192.168.1.0      192.168.2.254           20         32768 ?

*>i192.168.2.0      192.168.1.254           20    100      0 ?

* i192.168.44.0     192.168.1.254           20    100      0 ?

*>                  192.168.2.254           20         32768 ?

*> 192.168.45.0     192.168.2.254           20         32768 ?

*>i192.168.80.0     192.168.1.254           20    100      0 ?

*>i192.168.99.1/32  192.168.1.1             10    100      0 ?

*> 192.168.99.2/32  0.0.0.0                 10         32768 ?

* i211.11.117.0     192.168.1.254           20    100      0 ?

*>                  192.168.2.254           20         32768 ?



Total number of prefixes 12



[root@callisto:~#] netstat -rn

Kernel IP routing table

Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface

192.168.99.1    0.0.0.0         255.255.255.255 UH       40 0          0 wp1chdlc

192.168.99.2    192.168.1.254   255.255.255.255 UGH      40 0          0 eth1

192.168.99.0    0.0.0.0         255.255.255.252 U        40 0          0 wp1chdlc

172.16.0.128    192.168.14.2    255.255.255.128 UG       40 0          0 eth0

172.16.0.0      192.168.14.2    255.255.255.128 UG       40 0          0 eth0

211.11.117.0    192.168.1.254   255.255.255.0   UG       40 0          0 eth1

10.0.0.0        192.168.14.254  255.255.255.0   UG       40 0          0 eth0

10.0.1.0        192.168.14.254  255.255.255.0   UG       40 0          0 eth0

192.168.2.0     192.168.1.254   255.255.255.0   UG       40 0          0 eth1

192.168.80.0    192.168.1.254   255.255.255.0   UG       40 0          0 eth1

192.168.1.0     0.0.0.0         255.255.255.0   U        40 0          0 eth1

192.168.1.0     0.0.0.0         255.255.255.0   U        40 0          0 ipsec0

192.168.14.0    0.0.0.0         255.255.255.0   U        40 0          0 eth0

192.168.44.0    192.168.1.254   255.255.255.0   UG       40 0          0 eth1

192.168.45.0    0.0.0.0         255.255.255.0   U        40 0          0 eth1

127.0.0.0       0.0.0.0         255.0.0.0       U        40 0          0 lo

0.0.0.0         192.168.1.254   0.0.0.0         UG       40 0          0 eth1



callisto-bgpd# show ip bgp summary

BGP router identifier 192.168.1.1, local AS number 65000

6 BGP AS-PATH entries

0 BGP community entries

Dampening enabled.



Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

192.168.2.7     4 65000      46      46        0    0    0 00:39:42        7

192.168.14.2    4 65001      48      47        0    0    0 00:39:38        4

192.168.14.254  4 65003      50      47        0    0    0 00:39:38        4

192.168.44.1    4 65000      39      48        0    0    0 00:38:05        0



Total number of neighbors 4



callisto-bgpd# show ip bgp neighbors 192.168.2.7

BGP neighbor is 192.168.2.7, remote AS 65000, local AS 65000, internal link

 Member of peer-group INTERNAL for session parameters

  BGP version 4, remote router ID 192.168.2.7

  BGP state = Established, up for 00:40:44

  Last read 00:00:44, hold time is 180, keepalive interval is 60 seconds

  Neighbor capabilities:

    Route refresh: advertised and received (old and new)

    Address family IPv4 Unicast: advertised and received

  Received 47 messages, 0 notifications, 0 in queue

  Sent 47 messages, 0 notifications, 0 in queue

  Route refresh request: received 0, sent 0

  Minimum time between advertisement runs is 5 seconds



 For address family: IPv4 Unicast

  INTERNAL peer-group member

  Route-Reflector Client

  Inbound soft reconfiguration allowed

  Community attribute sent to this neighbor (both)

  7 accepted prefixes



Connections established 1; dropped 0

Local host: 192.168.1.1, Local port: 32923

Foreign host: 192.168.2.7, Foreign port: 179

Nexthop: 192.168.1.1

Read thread: on  Write thread: off



callisto-bgpd# show ip bgp neighbors 192.168.2.7 advertised-routes

BGP table version is 0, local router ID is 192.168.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete



   Network          Next Hop            Metric LocPrf Weight Path

*> 10.0.0.0/24      192.168.14.254           0    100      0 65003 i

*> 10.0.1.0/24      192.168.14.254           0    100      0 65003 i

*> 172.16.0.0/25    192.168.14.2             0    100      0 65001 i

*> 172.16.0.128/25  192.168.14.2             0    100      0 65001 i

*> 192.168.2.0      192.168.1.254           20    100  32768 ?

*> 192.168.44.0     192.168.1.254           20    100  32768 ?

*> 192.168.80.0     192.168.1.254           20    100  32768 ?

*> 192.168.99.1/32  192.168.1.1             10    100  32768 ?

*> 211.11.117.0     192.168.1.254           20    100  32768 ?



Total number of prefixes 9



callisto-bgpd# show ip bgp

BGP table version is 0, local router ID is 192.168.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete



   Network          Next Hop            Metric LocPrf Weight Path

*> 10.0.0.0/24      192.168.14.254           0             0 65003 i

*                   192.168.14.254                         0 65001 65003 i

* i                 192.168.7.254            0    100      0 65003 i

*> 10.0.1.0/24      192.168.14.254           0             0 65003 i

*                   192.168.14.254                         0 65001 65003 i

* i                 192.168.7.254            0    100      0 65003 i

*  172.16.0.0/25    192.168.14.2                           0 65003 65001 i

*>                  192.168.14.2             0             0 65001 i

*  172.16.0.128/25  192.168.14.2                           0 65003 65001 i

*>                  192.168.14.2             0             0 65001 i

*>i192.168.1.0      192.168.2.254           20    100      0 ?

*> 192.168.2.0      192.168.1.254           20         32768 ?

* i192.168.44.0     192.168.2.254           20    100      0 ?

*>                  192.168.1.254           20         32768 ?

*>i192.168.45.0     192.168.2.254           20    100      0 ?

*> 192.168.80.0     192.168.1.254           20         32768 ?

*> 192.168.99.1/32  0.0.0.0                 10         32768 ?

*>i192.168.99.2/32  192.168.2.7             10    100      0 ?

* i211.11.117.0     192.168.2.254           20    100      0 ?

*>                  192.168.1.254           20         32768 ?



Total number of prefixes 12



callisto-bgpd# show ip bgp 172.16.0.0/25

BGP routing table entry for 172.16.0.0/25

Paths: (2 available, best #2, table Default-IP-Routing-Table)

  Advertised to non peer-group peers:

  192.168.2.7 192.168.14.254 192.168.44.1

  65003 65001

    192.168.14.2 from 192.168.14.254 (10.0.0.1)

      Origin IGP, localpref 100, valid, external

      Last update: Fri May  2 12:54:37 2003



  65001

    192.168.14.2 from 192.168.14.2 (172.16.0.254)

      Origin IGP, metric 0, localpref 100, valid, external, best

      Last update: Fri May  2 12:54:37 2003



scar# show ip bgp summary

BGP router identifier 10.0.0.1, local AS number 65003

BGP table version is 19, main routing table version 19

12 network entries and 32 paths using 2316 bytes of memory

7 BGP path attribute entries using 420 bytes of memory

4 BGP AS-PATH entries using 96 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

Dampening enabled. 0 history paths, 0 dampened paths

BGP activity 12/49 prefixes, 32/0 paths, scan interval 60 secs



Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

10.0.1.2        4 65003     298     308       19    0    0 04:54:26        0

192.168.7.7     4 65000      66      69       19    0    0 00:58:15       10

192.168.14.1    4 65000      65      70       19    0    0 00:57:36       10

192.168.14.2    4 65001     303     307       19    0    0 04:54:24       10



scar# show ip bgp neighbors 192.168.7.7

BGP neighbor is 192.168.7.7,  remote AS 65000, external link

  BGP version 4, remote router ID 192.168.2.7

  BGP state = Established, up for 00:59:07

  Last read 00:00:07, hold time is 180, keepalive interval is 60 seconds

  Neighbor capabilities:

    Route refresh: advertised and received(new)

    Address family IPv4 Unicast: advertised and received

  Received 67 messages, 0 notifications, 0 in queue

  Sent 70 messages, 0 notifications, 0 in queue

  Route refresh request: received 0, sent 0

  Default minimum time between advertisement runs is 30 seconds



 For address family: IPv4 Unicast

  BGP table version 19, neighbor version 19

  Index 2, Offset 0, Mask 0x4

  Inbound soft reconfiguration allowed

  10 accepted prefixes consume 360 bytes

  Prefix advertised 10, suppressed 0, withdrawn 1

  Number of NLRIs in the update sent: max 2, min 0



  Connections established 1; dropped 0

  Last reset never

Connection state is ESTAB, I/O status: 1, unread input bytes: 0

Local host: 192.168.7.254, Local port: 179

Foreign host: 192.168.7.7, Foreign port: 1024



Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)



Event Timers (current time is 0x10FB800):

Timer          Starts    Wakeups            Next

Retrans            70          0             0x0

TimeWait            0          0             0x0

AckHold            67         37             0x0

SendWnd             0          0             0x0

KeepAlive           0          0             0x0

GiveUp              0          0             0x0

PmtuAger            0          0             0x0

DeadWait            0          0             0x0



iss:  939562101  snduna:  939563660  sndnxt:  939563660     sndwnd:  33580

irs: 2226264130  rcvnxt: 2226265600  rcvwnd:      16384  delrcvwnd:      0



SRTT: 300 ms, RTTO: 303 ms, RTV: 3 ms, KRTT: 0 ms

minRTT: 4 ms, maxRTT: 300 ms, ACK hold: 200 ms

Flags: passive open, nagle, gen tcbs



Datagrams (max data segment is 1460 bytes):

Rcvd: 135 (out of order: 0), with data: 67, total data bytes: 1469

Sent: 108 (retransmit: 0), with data: 69, total data bytes: 1558



scar# show ip bgp neighbors 192.168.7.7 received-routes

BGP table version is 19, local router ID is 10.0.0.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete



   Network          Next Hop            Metric LocPrf Weight Path

*  172.16.0.0/25    192.168.7.7                            0 65000 65001 i

*  172.16.0.128/25  192.168.7.7                            0 65000 65001 i

*  192.168.1.0      192.168.7.7             20             0 65000 ?

*> 192.168.2.0      192.168.7.7                            0 65000 ?

*  192.168.44.0     192.168.7.7             20             0 65000 ?

*  192.168.45.0     192.168.7.7             20             0 65000 ?

*> 192.168.80.0     192.168.7.7                            0 65000 ?

*> 192.168.99.1/32  192.168.7.7                            0 65000 ?

*  192.168.99.2/32  192.168.7.7             10             0 65000 ?

*  211.11.117.0     192.168.7.7             20             0 65000 ?



Total number of prefixes 10



scar# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route



Gateway of last resort is 192.168.14.1 to network 0.0.0.0



C    192.168.14.0/24 is directly connected, Ethernet1

B    192.168.44.0/24 [20/20] via 192.168.7.7, 00:50:56

B    192.168.45.0/24 [20/0] via 192.168.14.1, 00:50:46

     172.16.0.0/25 is subnetted, 2 subnets

B       172.16.0.128 [20/0] via 192.168.14.2, 04:48:45

B       172.16.0.0 [20/0] via 192.168.14.2, 04:48:45

     192.168.99.0/32 is subnetted, 2 subnets

B       192.168.99.2 [20/0] via 192.168.14.1, 00:52:46

B       192.168.99.1 [20/0] via 192.168.7.7, 00:52:26

B    192.168.80.0/24 [20/0] via 192.168.7.7, 00:50:56

B    211.11.117.0/24 [20/20] via 192.168.7.7, 00:50:56

     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

O       10.0.0.2/32 [110/7] via 10.0.1.2, 04:49:47, TokenRing0

C       10.0.0.0/24 is directly connected, Loopback0

C       10.0.1.0/24 is directly connected, TokenRing0

C    192.168.7.0/24 is directly connected, Ethernet0

B    192.168.1.0/24 [20/0] via 192.168.14.1, 00:50:46

B    192.168.2.0/24 [20/0] via 192.168.7.7, 00:50:56

S*   0.0.0.0/0 [1/0] via 192.168.14.1



scar# show ip bgp

BGP table version is 17, local router ID is 10.0.0.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete



   Network          Next Hop            Metric LocPrf Weight Path

*> 10.0.0.0/24      0.0.0.0                  0         32768 i

*> 10.0.1.0/24      0.0.0.0                  0         32768 i

*  172.16.0.0/25    192.168.7.7                            0 65000 65001 i

*                   192.168.14.2                           0 65000 65001 i

*>                  192.168.14.2             0             0 65001 i

*  172.16.0.128/25  192.168.7.7                            0 65000 65001 i

*                   192.168.14.2                           0 65000 65001 i

*>                  192.168.14.2             0             0 65001 i

*  192.168.1.0      192.168.14.1                           0 65001 65000 ?

*>                  192.168.14.1                           0 65000 ?

*                   192.168.7.7             20             0 65000 ?

*  192.168.2.0      192.168.14.1                           0 65001 65000 ?

*                   192.168.14.1            20             0 65000 ?

*>                  192.168.7.7                            0 65000 ?

*  192.168.44.0     192.168.14.1                           0 65001 65000 ?

*                   192.168.14.1            20             0 65000 ?

*>                  192.168.7.7             20             0 65000 ?

*  192.168.45.0     192.168.14.1                           0 65001 65000 ?

*>                  192.168.14.1                           0 65000 ?

*                   192.168.7.7             20             0 65000 ?

*  192.168.80.0     192.168.14.1                           0 65001 65000 ?

*                   192.168.14.1            20             0 65000 ?

*>                  192.168.7.7                            0 65000 ?

*> 192.168.99.1/32  192.168.7.7                            0 65000 ?

*                   192.168.14.1                           0 65001 65000 ?

*                   192.168.14.1            10             0 65000 ?

*  192.168.99.2/32  192.168.14.1                           0 65001 65000 ?

*>                  192.168.14.1                           0 65000 ?

*                   192.168.7.7             10             0 65000 ?

*  211.11.117.0     192.168.14.1                           0 65001 65000 ?

*                   192.168.14.1            20             0 65000 ?

*>                  192.168.7.7             20             0 65000 ?



scar# show ip bgp 192.168.44.1

BGP routing table entry for 192.168.44.0/24, version 18

Paths: (3 available, best #2, table Default-IP-Routing-Table)

  Advertised to non peer-group peers:

  10.0.1.2 192.168.7.7 192.168.14.2

  65001 65000, (received & used)

    192.168.14.1 from 192.168.14.2 (172.16.0.254)

      Origin incomplete, localpref 100, valid, external

  65000, (received & used)

    192.168.14.1 from 192.168.14.1 (192.168.1.1)

      Origin incomplete, metric 20, localpref 100, valid, external, multipath, best

  65000, (received & used)

    192.168.7.7 from 192.168.7.7 (192.168.2.7)

      Origin incomplete, metric 20, localpref 100, valid, external, multipath



scar# traceroute 192.168.44.1



Type escape sequence to abort.

Tracing the route to 192.168.44.1



  1 192.168.14.1 0 msec

    192.168.7.7 4 msec

    192.168.14.1 4 msec

  2 192.168.44.1 [AS 65000] 4 msec 0 msec 0 msec